Uploaded image for project: 'Hue'
  1. Hue
  2. HUE-2608

[oozie] Job log fetching can fail in Oozie HA mode with doAs impersonation

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not A Bug
    • Affects Version/s: 3.7.0
    • Fix Version/s: None
    • Component/s: app.oozie
    • Labels:
      None

      Description

      Oozie logs in Hue does not work well when Oozie is configured in HA mode. Essentially, DoAs user doesn't work for HA request. This happens because in HA one server will call other server as "tomcat user".

      http://oozie-server:4080/oozie/v2/job/jobid1-oozie_CB-W?show=log&allservers=false&doAs=sumeet&user.name=hue
      will be http://oozie-server:4080/oozie/v2/job/jobid1-oozie_CB-W?show=log&allservers=false&doAs=sumeet&user.name=oozie

      Potential fixes can be to add oozie as proxy user or drop doAs user from server to server call. Since the request is already authenticated, it should ok to call other server with oozie user. http://oozie-server:4080/oozie/v2/job/jobid1-oozie_CB-W?show=log&allservers=false&user.name=oozie

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              rickbernotas Rick Bernotas
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: