Uploaded image for project: 'Hue'
  1. Hue
  2. HUE-1258

Oozie workflow fraph display problem when email action is used

    Details

      Description

      Oozie workflow is poorly displayed when email action.

      Here is the workflow:

      workflow-app name="Xvlr-add-partition-subworkflow" xmlns="uri:oozie:workflow:0.3">
          <start to="Xvlr-add-partition-subworkflow-run" />
      
          <action name="Xvlr-add-partition-subworkflow-run">
              <java>
                  <job-tracker>${jobTracker}</job-tracker>
                  <name-node>${nameNode}</name-node>
                  <configuration>
                      <property>
                          <name>mapred.queue.name</name>
                          <value>default</value>
                      </property>
                  </configuration>
                  <main-class>ru.mrjob.general.oozieclient.oozieaction.AlterTableAddPartitionMain</main-class>
                  <arg>org.apache.hive.jdbc.HiveDriver</arg>
                  <arg>xvlr</arg>
                  <arg>${hive2JdbcUrl}</arg>
                  <arg>${inputDir}</arg> <!-- path to created data dir -->
                  <arg>hive</arg> <!-- user name -->
                  <arg>hive</arg> <!-- password -->
              </java>
              <ok to="job-workflow-end"/>
              <error to="send-failure-email"/>
          </action>
      
          <action name="send-failure-email">
              <email xmlns="uri:oozie:email-action:0.1">
                  <to>sergey.sheypak@lol.ru</to>
                  <subject>Failed archiver workflow with id: ${wf:id()}</subject>
                  <body>The wf ${wf:id()} has been failed. Message: ${wf:errorMessage(wf:lastErrorNode())}</body>
              </email>
              <ok to="kill"/>
              <error to="kill"/>
          </action>
      
          <kill name="email-kill">
              <message>Failed to deliver email notification about failed action: ${wf:errorMessage(wf:lastErrorNode())}</message>
          </kill>
      
          <kill name="kill">
              <message>Sub-workflow failed with error message ${wf:errorMessage(wf:lastErrorNode())}</message>
          </kill>
      
          <end name="job-workflow-end" />
      </workflow-app>
      

        Attachments

          Activity

            People

            • Assignee:
              romain Romain Rigaux
              Reporter:
              seregasheypak Sergey Sheypak
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: