Uploaded image for project: 'Hue'
  1. Hue
  2. HUE-2940

[core] DeprecationWarning: The posixfile module is deprecated;

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.9.0
    • Fix Version/s: 3.10.0
    • Component/s: core.api
    • Labels:
      None
    • Target Version:
    • Easy:
      Easy

      Description

      Module `posixfile` is deprecated it causes warning-message:

      ```
      DeprecationWarning: The posixfile module is deprecated; fcntl.lockf()
      provides better locking
      ```

      Use module `io` for those constants.

        Attachments

          Activity

            People

            • Assignee:
              ivanorlo Ivan Orlov
              Reporter:
              ivanorlo Ivan Orlov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: